HTTPS Fix для Opencart v2.X 1.0.0


1 скриншот

Описание файла

Небольшой мод, который заставляет Opencart работать корректно с обоими протоколами одновременно.
Как того требует Яндекс какое то время, при переезде на HTTPS. Для правильной работы фикса у вас должны отличаться HTTP_CATALOG и HTTPS_CATALOG  в config.php.


Также мод фиксит проблемы определения протокола, при нестандартных настройках связки nginx => apache.
 

Кроме вашего покорного слуги решению приложили руки @markimax и @savage4pro.

 

Если кто захочет заслать благодарности - куда слать у них в профилях.


Изменения в версии 1.0.0   Просмотреть список изменений

Выпущена

изменил расширение файла

 

fix_https.ocmod.xml