Recommended Posts

Решили делать новый сайт на хостинге AdminVPS 
Начну сначала скрытом тексте ниже мелкие проблемы которые были

Скрытый текст

Купон opencartfree0001  на месяца хостинга совершенно бесплатно не работает. Мб т.к я зарегистрировался стал партнёром и скинул им эту ссылку.
Панель ISPmanager5 не активизироваться автоматически даже после оплаты. Хотя ей можно пользоваться и в тестовом периоде. Активировать можно создав тикет в тех поддержку, мне её через чат на сайте хостинга активировали. Зайти можно добавив к IP адреса сервера :1500 пароль как от SSH

Создал пользователя FTP скопировал через него файлы, создал базу.
При выборе PHP 5.4.16 (native) при установки писалось что надо включить какое-то расширение, поэтому сменил на 7.0.21 (alt)  да и по новее. Вначале выбрал 5,4,16 т.к на старом сервере были эти настройки хотел побыстрее без проблем установить.
Сайт показывается, в админке после обновлений кеша модификаторов сайт перестаёт работать.
Когда нажимаю кнопку для перехода и активаций pro сборки появляется ошибка.

Скрытый текст

Warning: realpath(): open_basedir restriction in effect. File(/opt/php70/lib/php/modules) is not within the allowed path(s): (/var/www/foliant/data:.) in /var/www/foliant/data/www/foliant72.ru/admin/controller/pro/license.php on line 2Warning: file_exists(): open_basedir restriction in effect. File(/var/www/foliant/ioncube/ioncube_loader_lin_7.0.so) is not within the allowed path(s): (/var/www/foliant/data:.) in /var/www/foliant/data/www/foliant72.ru/admin/controller/pro/license.php on line 2Warning: file_exists(): open_basedir restriction in effect. File(/var/www/ioncube/ioncube_loader_lin_7.0.so) is not within the allowed path(s): (/var/www/foliant/data:.) in /var/www/foliant/data/www/foliant72.ru/admin/controller/pro/license.php on line 2Warning: file_exists(): open_basedir restriction in effect. File(/var/ioncube/ioncube_loader_lin_7.0.so) is not within the allowed path(s): (/var/www/foliant/data:.) in /var/www/foliant/data/www/foliant72.ru/admin/controller/pro/license.php on line 2Site error: the file /var/www/foliant/data/www/foliant72.ru/admin/controller/pro/license.php requires the ionCube PHP Loader ioncube_loader_lin_7.0.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation. 


Аналогичная проблема при установки шаблона революшен. Автор шаблона в ответ скинул http://forum.opencart-russia.ru/threads/reshenie-oshibki-open_basedir-restriction-in-effect-file-x-is-not-within-the-allowed-path-s-y.4626/ изменения в system/startup.php не помогло
Менял версий PHP нажимая Как модуль Apache  Панели ISPmanager5 иногда после смени настройки удалял файлы базу устанавливал заново не помогло. 
в настройках php переменной open_basedir ставил значение none не помогло.

в https://www.templatemonster.com/help/ru/open_basedir-restriction-in-effect-filex-is-not-within-the-allowed-paths-y.html не понимаю как можно отредактировать настройки Apache. 
Сейчас праздники к https://my.adminvps.ru/index.php у меня доступа нет и заказчики молчат. Есть к https://vps.adminvps.ru 

С наступающим рождеством, хорошего настроения)
Хочется как-то разобраться решить, а то и так долго тянется это, но я даже не знаю, а можно это как-то решить без тех поддержки или нет.

Изменено пользователем Zernycha
модер сказал логи под сполер кинуть

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Zernycha сказал:

Начну сначала

Картинки, код и логи уберите под спойлер!

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
11 час назад, SunnRi сказал:

Поставьте 5.6 (alt) или native (или пусть вам это сделают) и не ищите себе проблем :)

Спасибо помогло:)
Поставил 5.6.31 в расширениях установил:facepalm: ioncube заработало. с 7 не работает
Кст подскажите в версиях php чем (alt) от (native) отличается

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Столкнулся с такой же бедой на vps, тоже решилось понижением версии php

после переезда на vps все прям летает.... очень рад что ушли с дурацкого бегета

 

У меня вообще корректно работа проходит только на 5.3.3 native

на любой версии php alt прут ошибки

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
8 часов назад, Zernycha сказал:

Спасибо помогло:)
Поставил 5.6.31 в расширениях установил:facepalm: ioncube заработало. с 7 не работает
Кст подскажите в версиях php чем (alt) от (native) отличается

На сколько помню,а нэтив уже многие библиотеки включены по умолчанию.

Ну может еще что

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Потестил я adminvps, не понятна стала одна весчь

стоит opencart.pro 2.1+revolution шаблон

на всех версиях php акромя 5.6 и 7 сайт работает прелестно. Но вся бяда в том, что мне нужна версия не ниже 5,6 php...

у них стоит 5,6,31 (alt) и потом идет 7,0,21 и все модули типа симплы идут в отказ и не работают....

Как быть(((?

Скрытый текст

5a507402e97fe_-2.thumb.png.0cb904e3fcb509db9e0019e542cc4d5c.png

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, maxim72 сказал:

Потестил я adminvps, не понятна стала одна весчь

стоит opencart.pro 2.1+revolution шаблон

на всех версиях php акромя 5.6 и 7 сайт работает прелестно. Но вся бяда в том, что мне нужна версия не ниже 5,6 php...

у них стоит 5,6,31 (alt) и потом идет 7,0,21 и все модули типа симплы идут в отказ и не работают....

Как быть(((?

  Показать содержимое

 

Это не у них - это стандартная поставка версий php от isp.
Скорее всего у вас не заводится simple из-за отсуствия ioncube, который доставляется для нужной версии в один клик.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Yoda сказал:

Это не у них - это стандартная поставка версий php от isp.
Скорее всего у вас не заводится simple из-за отсуствия ioncube, который доставляется для нужной версии в один клик.

ioncube устанавливал сам лично в настройках php

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Yoda сказал:

Реально первый раз вижу такую проблему!
Проверьте стоит ли у вас Json для php... 

Вобщем тут косяки не с сервером а с какими-то недостающими настрйоками.

Вот сижу копашусь с настройками.... пок4а безрезультатно

И вы как всегда оказались правы, включил в сборку 5,6 php json пока полет нормальный....

 

На сервер не грешил, там ребята молодцы, саппорт работает очень оперативно. Без лишних траблов все вопросы решают поставленные.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, maxim72 сказал:

На сервер не грешил, там ребята молодцы, саппорт работает очень оперативно. Без лишних траблов все вопросы решают поставленные.

Если у вас не стоял ионкуб к 5.6  - у вас скорее всего либо ubuntu, либо minimal установка isp. 
С убунтой я не связываюсь, а вот когда накатывается пустая панель, либо вы ее самостоятельно накатили, возможны ситуации с отсуствием требуемого набора php-библиотек. По моему это как раз ваш случай.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
3 минуты назад, Yoda сказал:

 

Если у вас не стоял ионкуб к 5.6  - у вас скорее всего либо ubuntu, либо minimal установка isp. 
С убунтой я не связываюсь, а вот когда накатывается пустая панель, либо вы ее самостоятельно накатили, возможны ситуации с отсуствием требуемого набора php-библиотек. По моему это как раз ваш случай.

Тут дело было так. Мы купили vps pro, дали саппорту указ перенести со старого хостинга сайт и базу данных, они перенесли и установили все как им казалось, потом началась пляска с бубном почтовиком, поправили, потом вот с ионкубом, 

насчет убунты незнаю, пишут что centos стоит

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, maxim72 сказал:

Тут дело было так. Мы купили vps pro, дали саппорту указ перенести со старого хостинга сайт и базу данных, они перенесли и установили все как им казалось, потом началась пляска с бубном почтовиком, поправили, потом вот с ионкубом, 

насчет убунты незнаю, пишут что centos стоит

Если не победите - стукните в личку.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 минуту назад, Yoda сказал:

Если не победите - стукните в личку.

Проблема пока решилась )) как вы и говорили, установил для 5.6 недостающий json. После установки все заработало пока нормально.... Тестим дальше. Для меня это первый опыт подобный опыт работы с vps, это я как девственности лишился))) каждый день что-то новое познаю для себя))) сейчас пытаюсь наладить выгрузку заказов в 1С с сайта..... но это уже другая история, в которой танцев с бубном еще больше чем с php)))

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
2 минуты назад, maxim72 сказал:

Проблема пока решилась )) как вы и говорили, установил для 5.6 недостающий json. После установки все заработало пока нормально.... Тестим дальше. Для меня это первый опыт подобный опыт работы с vps, это я как девственности лишился))) каждый день что-то новое познаю для себя))) сейчас пытаюсь наладить выгрузку заказов в 1С с сайта..... но это уже другая история, в которой танцев с бубном еще больше чем с php)))

Там могут быть проблемы с проксированием secure-заголовков в apache. Но все решаемо.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, Yoda сказал:

Там могут быть проблемы с проксированием secure-заголовков в apache. Но все решаемо.

Ну вот, опять напугали меня страшными словами)) подскажите как это отразиться на работе магазина может? Чтобы сразу понять что что-то пошло не так

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
Только что, maxim72 сказал:

Ну вот, опять напугали меня страшными словами)) подскажите как это отразиться на работе магазина может? Чтобы сразу понять что что-то пошло не так

Никак. Если 1с ни в какую не захочет авторизоваться в магазин - копайте в этом направлении.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, Yoda сказал:

Никак. Если 1с ни в какую не захочет авторизоваться в магазин - копайте в этом направлении.

Спасибо... Один модуль подключается к базе mysql и ftp магаза, но почему то не выгружает заказы. А второй модуль только начал изучать

 

Ну все, 1с подключил.... вобьем товары, и полетели работать через 1с с сайтом

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу