RHCk

[C WWW] <-301-> [Без WWW]

Recommended Posts

В 05.12.2015 at 19:33, RHCk сказал:

Если пригодится кому, так и хорошо :)

здравствуйте)
а если у меня нет строки Options +FollowSymlinks как тогда поступать? и что эта строка означает?
спасибо)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
6 часов назад, Николай1989 сказал:

здравствуйте)
а если у меня нет строки Options +FollowSymlinks как тогда поступать? и что эта строка означает?
спасибо)

 

Хостинг какой?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

это какаето черная магия)))) так а если этой строчки нет?

3 часа назад, RHCk сказал:

 

 

8 часов назад, WarStyle сказал:

 

Хостинг какой?

 

https://www.ukraine.com.ua/

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Николай1989 сказал:

это какаето черная магия)))) так а если этой строчки нет?

 

 

 

https://www.ukraine.com.ua/

 

https://www.ukraine.com.ua/faq/oshibka-500-internal-server-erro.html#!8

 

Вам следует попробовать изменить: 

директиву Options +FollowSymLinks на Options +SymLinksIfOwnerMatch

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, WarStyle сказал:

 

https://www.ukraine.com.ua/faq/oshibka-500-internal-server-erro.html#!8

 

Вам следует попробовать изменить: 

директиву Options +FollowSymLinks на Options +SymLinksIfOwnerMatch

так у меня нет этой строчки)

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
1 час назад, Николай1989 сказал:

так у меня нет этой строчки)

 

Значит нужно добавить

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
В 08.07.2018 at 02:04, WarStyle сказал:

 

Значит нужно добавить

порядок куда добавить, имеет значение?или может вместо чего то?

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах
5 часов назад, Николай1989 сказал:

порядок куда добавить, имеет значение?или может вместо чего то?

 

Оригинал от 2.3.0.2.4:

Скрытый текст

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|\.ini|\.log|(?<!robots)\.txt))">
 Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^sitemap_pro.xml$ index.php?route=extension/feed/sitemap_pro [L]
RewriteRule ^yandex_feed.xml$ index.php?route=extension/feed/yandex_feed [L]
RewriteRule ^system/download/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Можете сделать так же.

Поделиться сообщением


Ссылка на сообщение
Поделиться на других сайтах

Создайте аккаунт или войдите для комментирования

Вы должны быть пользователем, чтобы оставить комментарий

Создать аккаунт

Зарегистрируйтесь для получения аккаунта. Это просто!

Зарегистрировать аккаунт

Войти

Уже зарегистрированы? Войдите здесь.

Войти сейчас

  • Сейчас на странице   0 пользователей

    Нет пользователей, просматривающих эту страницу